which version of java development kit should you install